Hallar duplicados en Excel

Hallar duplicados en Excel

Para realizar el mantenimiento de una BBDD en Excel, podemos localizar los posibles duplicados en un rango de datos utilizando el formato condicional y la función CONTAR.SI.

=CONTAR.SI(A:A;A2)>1

A continuación, vamos a crear un archivo en Excel compuesto por un listado de direcciones de correo electrónico. Añadiremos algunas direcciones duplicadas con el fin de mostrar el uso de esta función y por último ordenaremos los resultados mediante filtros, lo cual nos permitirá fácilmente eliminar aquellas direcciones repetidas.

1. Creamos un nuevo archivo en Excel.
2. Añadimos en la primera fila los títulos de los campos:

  • Email
  • Duplicado

3. Añadimos un listado de direcciones de correo electrónico: ejemplo@email.com...
4. Incluimos alguna dirección de correo repetida.

neo 2.0 - Hallar duplicados en Excel - 1

5. Escribimos la función =CONTAR.SI(A:A;A2)>1 en la celda B2.

neo 2.0 - Hallar duplicados en Excel - 2

Nota: Si nuestro campo Email se correspondiese con la columna D, y la primera dirección de correo electrónico apareciese en la fila 3, nuestra función quedaría =CONTAR.SI(D:D;D3)>1.

6. Ampliamos el rango al resto de filas. Situamos el cursor en la esquina inferior derecha, éste cambia por una cruz negra. Arrastramos sin soltar hasta la última fila con datos.

neo 2.0 - Hallar duplicados en Excel - 3

7. Los datos duplicados se identifican como Verdadero, los únicos como Falso.

neo 2.0 - Hallar duplicados en Excel - 4

8. Ordenamos los datos para identificar con mayor facilidad los duplicados. Seleccionamos las dos primeras celdas y hacemos clic en la pestaña "Datos" > "Filtro".

neo 2.0 - Hallar duplicados en Excel - 5

9. Ordenamos los datos de menor a mayor (Ordenar de A a Z).

neo 2.0 - Hallar duplicados en Excel - 6

10. Ampliamos la selección para ordenar junto con el campo email, el campo Duplicado.

neo 2.0 - Hallar duplicados en Excel - 7

11. Una vez ordenados los datos, ya podemos proceder a eliminar los duplicados.

neo 2.0 - Hallar duplicados en Excel - 8

Publicar un comentario

1 Comentarios

web designer india ha dicho que…
Thanks for sharing the tutorial...
web designer india